SimWind Project

U

User 6634

Dazu müsste man doch so etwas in der Art nutzen können. einen Flexschlauch drauf und gut

Systemair Rohrlüfter LTI - 220 m³/h ø125 mm | eBay

rohrlüfter 100 | eBay

Oder so etwas ??

Conrad Radiallüfter 12 V Grau im Conrad Online Shop | 570095

570095_LB_02_FB.EPS_80.jpg
 
Zuletzt bearbeitet:
U

User 10145

Hi Steffen,
hast du es inzwischen hinbekommen? Benutzt du den Pololu Mini mit 6 Kanälen? Wenn ja dann kann ich vlt ein wenig mein selbstgeschriebenes Programm für mein GForce Seat Projekt umschreiben, damit sie den Pololu füttern. Laufen tut das Programm aber nur mit iRacing!
 
U

User 8308

Man müsste doch nur den Wert des dataoutput, welcher die Geschwindigkeits Anzeige bei z.B. FanaLeds bei jeder Sim ansteuert,nehmen und diesen Wert für eine Digitale Lüftersteuerung nutzen.


Sent from my iPhone using Tapatalk
 
U

User 10031

also hinbekommen habe ich es noch nicht!
Habe den Pololu mini mit 6 Kanälen!

Habe momentan im X-sim nur ein Profil für Iracing! Im X-Sim Convertor nehme ich bei Math Setup Input 22: Current Speed

Das dürfte das sein was ich brauche...
Das problem das ich momentan habe, ist das wenn ich auf den grünen Start Button drücke, das die Meldung: X-sim extractor not detected kommt!

X-sim extractor läuft aber 100%!!!

@Benedikt, wenn du mir sowas umschreiben könntest, wäre das echt genial!:]
 
U

User 10145

Hier, probiers mal aus:
Netload Serious Filehosting - Netload

Du stellst in dem Reiter Hardwaresetup nur den Kanal an dem der ESC angeschlossen ist ein und den allgemeinen Multiplikator. Ich habe jetzt mal 1000 % als Standardwert eingerichtet, da bei meinem Servo dann mit dem Williams der komplette Weg abgedeckt wurde. Aber das musst du ausprobieren. Die Min/Max Werte für die Ausgabe an den Pololu kannst du so lassen. Aber auch hier darfst du natürlich rum probieren, starte im Main-Reiter die SimWind Ausgabe und stelle dann im Hardwarereiter den Mindestwert ein(sprich, wenn der Motor sich gerade aufhört zu drehen, den Wert benutzt er dann als Nullwert und addiert ab da einfach auf). Den Maxwert kannst du auch einstellen falls es dir zu stürmisch oder wie mir damals als ich das system damals noch hatte zu laut. Vergiss das Abspeichern der Einstellungen nicht.

Damit du nachvollziehen kannst, was er ausgibt (und du übrigens in dem Textfeld unten im Debugfenster verfolgen kannst), das Programm arbeitet nach folgener Formel:

Mindestwert+(Geschwindigkeit*3.6*Multiplikator) Geschwindigkeit werden in m/s ausgegeben, deswegen die 3,6

Kommst du über den maximalen Wert ignoriert er diesen und nimmt halt den eingestellten Maximalwert (es kommt zum Clipping)

Ich hoffe es klappt bei dir so alles auf Anhieb. Wenn ich das Programm soweit habe, dass man Fahrzeugprofile abspeichern kann, lad ich es mal hoch.

PS.: und lass mal in nem Video dein fertiges Projekt sehen, wenns denn läuft!
 
Zuletzt bearbeitet:
U

User 10031

Hi Benedikt,
Danke für das Programm! habe es grad mal ausprobiert, aber leider kommt immer ne Fehlermeldung wenn ich Iracing starte!

er sagt mir, das er die Datei formulamazda.png nicht finden kann?!?

Edit: hab einfach nen eigenes png erstellt...

Aber sobald ich auf Start drücke, bekommt der Regler nur ein vollgas signal!

Was könnte das sein?

Edit2:, Also ich bekomme es nicht hin!
Jetzt dreht er schon bei 1kmh auf volltouren! Wie kann ich denn einstellen, das er Liniear hochdreht?
Hab bei minimal Outpur Value jetzt mal 0 gewählt, und bei Max bin ich bei 750, aber ändern tut sich da nix?!
 
Zuletzt bearbeitet:
U

User 10145

Ja das mit den Bildern kann schon mal passieren, leider werden die Fahrzeuge auf der Homepage manchmal anders genannt als im Spiel. Eigentlich sollten alle Fahrzeuge im gfx ordner drin sein. Einfach das Bild, was er nicht findet umbennen und dann gehts, oder wie Du es schon getan hast, ein Eigenes erstellen.


Das er nicht richtig ausgibt kann aus meiner Sicht nur 2 Gründe haben. Du kannst ja die Ausgabe im Debugfenster beobachten.
Der Wert vor dem Schrägstrich ist was aus dem Spiel ausgelesen wird, das dahinter ist der Wert der an den Pololu gegeben wird.

Fehlermöglichkeit 1:
Was für werte hast du denn im Maestro (über das Pololu Maestro Control Center) eingestellt?
Ich habe diese Werte, die auch werkseitiger Standard sind:
Unbenannt-1.jpg
Sollten die Werte abweichen, versuche sie so einzustellen und mit Save rechts unten abzuspeichern. Vergiss nicht das Programm zu schließen, bevor du den ServoSeatCommander startest, da immer nur ein Programm mit dem Chip arbeiten kann!

Fehlermöglichkeit 2:
Der ESC ist falsch kalibriert. Meinen ESC konnte man kalibrieren, wenn der ESC angschlossen war, aber kein Strom für den Motor (die zwei dicken Kabel). Der ESC hat dann ein Signal ausgegeben, das ein Brummen oder eher Quietschen im Motor erzeugt. Der Motor piept dann wieder Wecker morgens.Jetzt gibt man über den Regler (idR die Fernsteuerung, bei uns der Pololu) den Maximalwert aus und schaltet den Strom für den Motor zu. Jetzt startet die Kalibrierung.
Das ganze ist von ESC zu ESC unterschiedlich. Da musst du das Handbuch von deinem raussuchen.

Hier hast du nochmal ne neue Version. In der hab ich mal die Bildausgabe der Fahrzeugerkennung auskommentiert, sodass die nicht mehr aktiv ist und damit auch nicht mehr meckern kann.
Zusätzlich hab ich zwei neue Buttons in der Hardwarekonfiguration eingebaut mit denen du Maximalwert und Minimalwert sofort ausgeben kannst. Das sollte die Konfiguration des ESC erleichtern.
Solltest du den ESC kalibirieren, versuch möglichst einen großen Maximalwert zu nutzen. Ich empfehle dir Standardwerte 3900 und 8000.

EDIT:
Hab eben nochmal mein alten ESC und die Turbine ausgepackt. Klappt wunderbar, aber auch erst nachdem ich die ESC neu kalibriert hatte! Nur das Anspringen des Motors kommt immer etwas plötzlich, ist aber auch gebraucht und nicht mehr der jüngste und braucht deswegen wahrscheinlich einen hohen Anlaufstrom.

Und noch was, beim Blick ins Handbuch meines ESC hab ich festgestellt, das ich ihn sowohl mit linearen als mit exponentiellen Anstieg laufen lassen kann!
 
Zuletzt bearbeitet:
U

User 10031

also ich bekomme es echt nicht hin!
Der Motor dreht bei 1kmh schon auf vollspeed.

Mein Pololu ist genauso Konfiguriert wie bei dir.

Als ESC nehme ich allerding momentan zum testen einen vom RC Car! Ist ein LRP Sphere Competition.
Programmiert ist er Linear, alles andere macht beim RC-Car ja keinen Sinn:)
 
U

User 10145

tja, damit könnte es natürlich zusammenhängen... Wie bereits gesagt, bei mir funktionierts einwandfrei. Vielleicht solltest du es mal mit nem ESC für Flieger ausprobieren.
 
U

User 8308

Was brauche ich denn jetzt alles für Simwind?


Sent from my iPhone using Tapatalk
 
U

User 10145

Solltest du es nach dem X-Sim System aufbauen:

-Impeller mit Brushless Motor (die Propeller aus den Styropor-RC-Flugzeugen)
-ein Regler für den Brushlessmotor (auch ESC genannt) bis 40A (abhängig vom Motor)
-einen Blei-Säure-Akku (Säure ist wichtig, kein Gel!) ca. 4-7Ah bei 6 bis 7,4V
-ein Schaltnetzteil das den Akku konstant lädt mit mindestens 300mA
-Pololu Maestro Mini 6 Channel RC-Servo Controller (gibts bei mehreren deutschen Anbietern)
-Kabel Anschlüsser und nen Schalter der hohe Ströme ab kann (ca 20-40A)

Wenn mans sicher haben will und den ESC vor Überlast schützen möchte hängt man noch ne Halterung mit KFZ-Sicherung zwischen Batterie und ESC.

Hab damals um die 70€ ausgegeben. Empfehlenswert ist das System aber nur für Leute die mit geschlossenen Headset fahren. die Impeller sind nämlich sehr laut, da sie mit bis zu 18.000U/min drehen.

Für ne genaue Anleitung such dir den Beitrag aus dem X-Sim Forum. Als Software kannst du meine benutzen, die ich noch weiter entwickeln werde. Bin aber gerade in Dänemark und ab nächster Woche 2 Wochen auf Mallorca ;). Entspanntes Studentenleben halt. Dann werd ich mich wieder an die Software setzen und meinen eigenen Ultraforce SimSeat weiter bauen:P
 
U

User 8308

Einen 90er impeller mit 6s Regler habe ich noch in meinem Freewing Eurofighter.Damit könnte man wirklich realistische Windgeschwindigkeiten für Open Wheeler erzeugen :-) kann man das System nicht auch mit 120er Gehäuselüftern umsetzen?Diese wären deutlich leiser und würden für meine Zwecke eigentlich schon ausreichen.


Sent from my iPhone using Tapatalk
 
U

User 10031

6S ist halt schon ziemlich heftig.

Ich wollte nen 3S Setup mit nem 13,8V 70A Netzteil realisieren.
Aber werde echt mal nen anderen Regler testen müssen (was dann erst am WE möglich ist)

edit: Aber eigendlich kann es nicht an meinem Regler liegen!
Per Pololu Config Tool, kann ich ihn richtig schön Linear hochdrehen lassen.
 
U

User 10145

mmh, also wenn das klappt, dann weiß ich auch nicht weiter. da muss ich zuhause nochmal n bissl rumprobieren, vlt mal meinen ESC anders Programmieren
 
U

User 10031

Am we werde ich auch noch was rumprobieren. Irgendwie muss es ja klappen. Habe irgendwie den verdacht, das die outputdaten irgendwie nicht stimmen.
 
U

User 10145

Ich werde einfach nochmal ein Programm schreiben wo du per Schieberegler den Output bestimmen kannst. Genauso wie im Pololu Tool, basierend auf dem SDK Beispiel. Bin aber erst Montag wieder zu Hause...
 
Oben