OSW Setup - Granity - Argon & Kollmorgen

U

User 11065

der spannsatz ist stufenlos verstellbar, auf der motorwelle. wenn du den spannsatz löst und weißt, wo der index genau ist, kannst du die motorwelle von hand so drehen, das der index auf mittelstellung oder in der nähe ist. natürlich im ausgeschalteten zustand. im mmos tool erkennst du dann, das der angezeigt offset nahe 0 ist oder nahe dem höchsten wert, je nachdem wo der index neben der mittelstellung sich befindet. ich würde raten den index an einen wert nahe bei 0 zu legen, also 100 oder 500 oder so ähnlich, da die motoren dazu tendieren nach rechts zu drehen, wenn das phasing beginnt. alles natürlich immer vorausgesetzt, man schaltet das system erst ein, wenn das lenkrad in der mittelstellung steht. wenn es irgendwo steht und man einschaltet (was theoretisch auch kein problem ist), muss man das lenkrad wieder einmal über den index drehen. man könnte auch darauf verzichten "index auswerten" auszuhaken, dann braucht man das nicht, aber davon rate ich ab, mit index ist es immer sicher, das es immer gleich funktioniert, weil die software so einen fixpunkt hat, von der sie den encoderwert errechnen kann
 
U

User 20921

Danke Jasmin für den top Hinweis, habs umgesetzt, funktioniert einwandfrei, muss das Lenkrad ca. 5° nach links drehen von der 12 Uhr Marke aus!


Gesendet von iPhone mit Tapatalk
 
U

User 11065

sorry, hatte es nicht geschafft auf deine E-Mail zu antworten, aber nun scheint es ja zu funktionieren ;)
 
U

User 20921

Kein Stress, hab somit wieder einiges dazugelernt trotzdem danke!

Aber das mit dem Notaus wäre trotzdem noch interessant.
 
U

User 11065

ich schreib dir dazu nochmal, ich muss selber nochmal auf die platine sehen, wie der verkabelt ist. hinten ist ein Sub-D9 Stecker/Buchse am Gehäuse, da wird der Not-Aus angeschlossen, ich weiß aber gerade nicht auswendig, welche beiden Pins es sind.

wird aber sicher noch ein paar tage dauern, da ich mein zeugs erstmal durchsuchen muss, wo ich den rest hingelegt hab. irgendwo im keller, die frage ist nur wo und in welchem karton :D
 
U

User 20921

Alles klar, das wäre super!
Schreib mir einfach mal wenn du was gefunden hast


Gesendet von iPhone mit Tapatalk
 
U

User 16363

hallo zusammen, schreibe hier mal rein bin mir aber nicht sicher ob es der richtige tread ist.

nach meinem firmwareupdate das nicht geklappt hat, musste ich die stm32 komplett rebooten und wieder beladen mit infos.

jetzt kommt das andere problem, da ich keine prt_sc gemacht habe von der granity, stehe ich im nimmerland
ich habe in meiner Granity Software überal nullen drin. kann mir jemand sagen was ich da genau einstellen muss?

ich habe die kleine Mige
den 10000 encoder
die argon mit der MMos

über eure hilfe würde ich mich freuen.

liebe grüsse aus der verschneiten schweiz
 
Oben