Hilfe mit Modem

U

User 69

Hi, Leute!

Wie Ihr vielleicht wisst, schlage ich mich seit einiger Zeit mit einem seltsamen Problem bei meinem Modem rum:

Ich habe ein 56K Modem und einen normalen Telefonanschluss.
Wenn ich nun N4 fahre und mich jemand auf meiner Leitung anruft passiert folgendes:

Es erscheint: 10035 - Error detected on network device

Danach fliege ich entweder ganz raus oder ich verliere durch Warp Runden.

Das seltsame ist, dass ich diesen Fehler vorher nie mit meinem Modem hatte, auch wenn mich jemand angerufen hat. Der Fehler taucht periodisch seit ca. 1 1/2 Monaten sporadisch auf. Zuerst dachte ich, es liege an meiner ISDN-Telefonanlage, die ich zuhause habe. Jetzt, wo ich in einer anderen Wohnung bin (mit normalem Anschluss) ist der Fehler noch nie aufgetreten bis zu dieser Woche.

Vielleicht wisst Ihr, wie ich den Fehler beheben kann.

MANY THANKS!!!!!!!!!!!!!!

Grüsse,
 
U

User

Es scheint so, als ob das Modem "erreichbar" ist. Also Irgendwo scheint eingestellt worden zu sein, daß Fax/Mailbox/o.ä. auf Anrufe reagieren soll. Irgendeine Software läuft im Hintergrund (nicht im Taskmanager, so ein Programm startet bei einem Anruf) oder das Modem ist generell so eingestellt, daß es auf Anrufe reagieren soll.
Dabei ist egal, ob es die richtige nummer ist oder nicht. Das System schaut erstmal, ob es mit dem eingehenden Anruf etwas anfangen kann. Das kann zum Absturz der Netzwerkverbindung (nichts anderes ist die Verbindung ins Internet) führen.
Hatte ich mit ISDN auch mal. Hab lange suchen müssen. War eine Standardeinstellung in Fritz.
Evtl. gibt es bei Dir so was Ähnliches.

Im Übrigen kann man das bei einer Telefonanlage (in Deiner anderen Heimat?) unterbinden, indem man den Port nur für ausgehende Leitungen konfiguriert. Dann kriegt das Modem nichts mit.
 
U

User 69

Hmm.. Ich habe kein Fax-Programm laufen und in den Modem-Einstellungen finde ich auch nichts derartiges. Mit dem Reagieren auf Anrufe hast Du recht. Wenn mein PC ausgeschaltet ist und ich einen Anruf bei eingesteckter Modemverbindung habe, fährt der Rechner hoch.

Ne Ahnung wo ich das Ausschalten kann, René?

Kann es etwas mit der Fehlerkorrektur zu tun haben? Soll ich die mal ausschalten??

Soweit vielen Dank für die Hilfe!!!
 
U

User 69

So jetzt habe ich die Fehlerkontrolle ausgeschaltet und mich anrufen lassen.

Ich fliege nicht mehr raus!!!

Aber war das wirklich die Lösung oder nur Zufall????

Vielleicht habt Ihr noch ne Idee!

Danke,
 
U

User

Scheint doch zu gehen :)

Die Hardwarefehlerkorrektur AUS, die Softwarefehlerkorrektur EIN

Du kannst auch mal den Empfangspuffer des COM-Ports verkleinern (eine Stufe). Geht auch über Gerätemanager - Anschlüsse.

Ansonsten kann ich ja mal (wenn ich die Zeit finde) morgen in meinen Unterlagen schauen (knowledgebase Microsoft. Irgendwo sollte es eine direkte Lösung zu Deiner Fehlermeldung geben.

Zudem kann es doch nicht sein, daß kein Anderer hier etwas dazu zu sagen hätte? Hab doch schon mehr hier gelesen :)
 
U

User 93

Original von Rene_Stachorra
Zudem kann es doch nicht sein, daß kein Anderer hier etwas dazu zu sagen hätte? Hab doch schon mehr hier gelesen :)

Nope,

hab ISDN und da is nix mit Problemen (das is auch alles was die TeleDOOF hinbekommt X( )
 
U

User 20

Hi Michael,

vielleicht liegts auch an ganz was anderem!

Hast Du evtl. die automatische Verbindungstrennung
im Internet Explorer aktiviert???

Gruss Matthes
 
U

User

Das einzig Sinnvolle, was ich zu dem Code gefunden habe:

Resource temporarily unavailable.

This error is returned from operations on non-blocking sockets that cannot be
completed immediately, for example recv when no data is queued to be read from
the socket. It is a non-fatal error, and the operation should be retried later.
It is normal for WSAEWOULDBLOCK to be reported as the result from calling
connect on a non-blocking SOCK_STREAM socket, since some time must elapse for
the connection to be established.

und
Windows Sockets code Error Description
------------------------------------------------------------------------

WSAEWOULDBLOCK 10035 Operation would block.


Also war das mit dem Ausschalten der Fehlerkontrolle schon richtig (6.Sinn,wa?). :)
 
U

User 69

Vielen Dank für Deine Hilfe und die Fehler-Recherche , René!!!! :D

Hoffentlich hält die Verbindung jetzt :D :D :D

Bis demnächst auf der Strecke,
 
U

User 79

@Michael

Manchmal sind auch die NTBa's defekt.Hab damit bei einigen Leuten echte Probs gehabt.Allerdings nur bei denen der "Terrorkom".In der Regel werden diese anstandslos ersetzt da dies bei der Terrorkom bekannt ist.



@ Alle

Wer es noch nicht kennt.....Ach ich poste dies in einenm extra Thread.
 
U

User

@Ralf, er hat keinen NTBA ;)

Aber durch Deine Hilfe hab ich was auf der Seite gefunden:

@Michael:
Verbindungsabbrüche durch Trägerverlust verhindern:
Anleitung: Bei häufig auftretenden Verbindungsabbrüchen des Modems durch den Verlust des CTS-Trägersignals lässt sich eine Verbesserung dadurch erzielen, dass man unter Modem/Eigenschaften/Einstellungen/Erweitert/weitere Einstellungen mit dem Eintrag S10=50 dem AT-Register S10 den Wert 5 Sekunden zuweist. Damit hällt das Modem die Verbindung noch 5 Sekunden lang aufrecht wenn das Trägersignal verschwunden ist. Der Standardwert liegt bei 2 Sekunden.

Das hört sich auch gut an :), vielleicht solltest Du das auch noch machen. Nur für alle Fälle ;)
 
U

User 79

@Rene

Hat Michael nicht irgendwas mit ISDN erzählt ?( .

Mit dem Trägersignal find ich auch interressant.Und die Einstellungen bringen wirklich etwas :D .

Ehhh jett hab ichs auch gelesen.Kein Isdn. :O
 
U

User 69

Vielen Dank für Deine Mühe, René!

Aber leider steht bei mir nix von S10 = 50 :)

Sondern das steht da: &FX3&C1&D2H0%C0W2

Welche 2 muss ich denn jetzt in eine 5 Umwandeln? :D

Grüsse,
 
U

User

np ;) :)

einfach hinten dran schreiben S10=50

Also, daß es dann so aussieht: &FX3&C1&D2H0%C0W2S10=50


Und wehe, das passiert nochmal mit Deinem Abbruch. Dann holst Du Dir aber ISDN!! :D
 
U

User

:D das wäre ja sogar ein richtiges Geschenk :D An Dir komme ich ja sonst kaum vorbei ;)

Ich sach dann Bescheid, wenn ich's brauch'! :)
 
Oben