Assetto Corsa Virtual Reality

U

User 162

Hi,
sollte man die FPS im Content Manager, wenn man z.B. eine Reverb hat, auf 90FPS (Limit Framerate) begrenzen oder ist das egal?.
 
U

User 22055

Soweit ich das beim Durchstöbern richtig gesehen habe, wurde bislang hauptsächlich über die Einstellungen für die Oculus Rift gesprochen. Ich darf nun seit kurzem eine Rift S mein Eigen nennen und muss gestehen - ich bin VR-Einsteiger.

Welche Einstellungen sind denn identisch und welche sollte ich bei der Rift S z.B. ändern? Die Auflösung ist in der Rift S ja z.B. höher. Spielt das eine Rolle?

Danke euch
 
Zuletzt bearbeitet:
U

User 5180

Hi Alex,

kannst du so übernehmen. Die Rift S benötigt nur 80 FPS. Sollte sich ausgleichen.
 
U

User 22702

Virtual Desktop Problem

Moin, ich bin komplett neu bei Assetto Corsa.
Ich benutze die Valve Index mit den Index Controllern und Virtual Desktop um keinen Monitor für die Menüs zu benötigen...dachte ich zumindest das es geht...
Leider schließt aber mein Pc nach dem Rennen in VR immer das Spiel und ich komme zurück zu Steam VR und nicht etwa wie gedacht wieder in das Assetto Corsa Menü.

Was mach ich falsch? Gibt es eine spezielle Einstellung im Menü?

2 bis 3 mal die Home Taste auf den Index Controller drücken (was anscheinend bei der Rift geht) funktioniert bei der Index leider nicht.
Bitte helft mir ich will doch unbedingt von Project Cars auf Assetto Corsa wechseln...nur kann ich nicht ständig den Fernseher in Beschlag nehmen wo mein Pc angeschlossen ist...findet meine Frau nämlich nicht so gut :)

Grüße Matthias
 
U

User 14359

Hat die Index nicht einen eigenen Virtual Desktop? Ich habe auch eine Index. Sobald ich sie aufsetze drücke ich die Home Taste (unterhalb der Brille links), dann kann ich einen meiner 3 angeschlossenen Bildschirme auswählen und von dort aus alles steuern (Bestätigung mit der gleichen Taste oder mit der Maus). Die Controller brauche ich dafür gar nicht.

Cheers
 
U

User 162

Ich schreibe das hier jetzt auch nochmal.
Ich bin letzte Woche das AC Event auf der NOS mit der HP Reverb VR-Brille gefahren und da waren am Anfang fast 60 Leute auf dem Server.
Ich hatte da mit einem i9-9900k (@4900MHz), 2080Ti und 32GB 3200 Ram einige Performanceprobleme und ständig immer wieder Framedrops und konnte die 90 FPS nicht halten und dann hatte es natürlich immer massiv geruckelt. Auch wenn ich das "motion reprojection" auf Auto umgestellt hatte, ruckelte es immer ein wenig wenn es von 90FPS auf 45FPS hind un her gesprungen ist. Habe dann das "motionvector" für feste 45 FPS eingestellt, damit war es dann fahrbarer, aber so richtig flüssig fuehlte sich das auch nicht an, bei der Rift fühlten sich 45FPS einfach besser an. Das Problem scheint wohl CPU bedingt zu sein, eine CPU Warnung hatte ich aber nicht, laut FPSVR lag die CPU bei 20-25% und die GPU bei 50-60% Auslastung.
Mir ist auch aufgefallen, wenn man in die Mercedes Arena einbiegt und dann Richtung Riesenrad fährt/schaut es immer zu Framedrops kommt. Wenn ich z.B. stehen bleibe und auf das Riesenrad schaue, habe ich nur 65-75 FPS, schaue ich dann nach Links wieder die vollen 90 FPS. Überhaupt habe ich den Eindruck egal wo man zur Zeit auf der Strecke ist, wenn es in etwa Richtung Riesenrad oder Boxen geht, die Framedrops kommen. Mich würde mal interessieren, ob ihr da auch Framedrops habt?. Muss ich nochmal genauer schauen, vielleicht habe ich noch irgendwo einen Haken im CM vergessen. Ich habe den CSP/SOL installiert und die empfohlenen Einstellungen dafür auch gemacht.
An welche Einstellungen kann man denn noch drehen, die die CPU weniger belasten?.
Wenn ich z.B. die Auflösung der Reverb von 150% auf nur 30 % stelle, ändert sich an den Framedrops nichts. Ich kann die bis auf 250% hochstellen, dann ereicht die GPU erst ihre 90% Auslastung, da sollte ja dann eigentlich die CPU das Problem haben. Hätte ich jetzt nicht gedacht bei einem 9900k .
 
U

User 22702

Hat die Index nicht einen eigenen Virtual Desktop? Ich habe auch eine Index. Sobald ich sie aufsetze drücke ich die Home Taste (unterhalb der Brille links), dann kann ich einen meiner 3 angeschlossenen Bildschirme auswählen und von dort aus alles steuern (Bestätigung mit der gleichen Taste oder mit der Maus). Die Controller brauche ich dafür gar nicht.

Cheers

Vielen Dank! Der Tip war genial...jetzt klappt es, ich musste nur noch den Kinomodus bei SteamVR deaktivieren und nun geht es sogar ohne die Controller.
Perfekt du hast mir sehr geholfen.

Grüße
 
U

User 4396

Habe dann das "motionvector" für feste 45 FPS eingestellt, damit war es dann fahrbarer, aber so richtig flüssig fuehlte sich das auch nicht an, bei der Rift fühlten sich 45FPS einfach besser an.
Ich muss sagen, dass Oculus mit ihrem ASW-Modus einen deutlich besseren Job machen. ASW läuft so gut, dass man es kaum merkt, dass hier nur 45fps statt 90fps genutzt werden. Die extrapolierten Frames fallen jedenfalls nicht dramatisch auf.
Seitdem ich von der Oculus CV1 auf die Index gewechselt hab, bin ich nun auf SteamVR mit Motion Smoothing und/oder Rückprojektion angewiesen. Und das läuft leider bei Weitem nicht so gut wie ASW von Oculus.

Framedrops in der Mercedes-Arena in Richtung Riesenrad (obwohl in AC da keins steht) hab ich auch. Das hab ich aber nicht nur in AC, sondern auch in rF2. Vermutlich weil da eben Teile des Fahrerlagers ins Blickfeld kommen und die Objekte eventuell etwas Optimierungbedarf bzgl. LODs hätten.
 
U

User 14359

Du brauchst den Kinomodus nicht zu deaktivieren (den gibts??:happy:) . Unten ist die aktive Sim zu sehen, einfach mit dem Punkt drauf zielen, mit der Headset Taste bestätigen und schwupps...
 
U

User 4396

Funktioniert VRSS mit Assetto Corsa? Hab es gestern mal über den Nvidia Inspector aktiviert, aber irgendwie seh ich keinen Unterschied. Falls es funktioniert ... gibt es da noch einen Trick, und wie kann man das am besten testen?
 
U

User 4396

Ich werf hier mal eine Sache rein, um vielleicht eine Lösung zu finden, falls es eine geben sollte.

Ich bin mit der Performance in AC extrem unzufrieden. Ich fahre in VR mit Valve Index und inkl. Shader-Patch und Sol. Als CPU läuft bei mir ein i7-6700K mit 4,4GHz und erst kürzlich hab ich auf eine RTX 2070 Super geupdatet. Eigentlich Hardware, womit ich doch wenigstens auf niedrigen bis mittleren Grafikdetails konstante 90fps erreichen sollte. Doch dem ist leider nicht so.

Im letzten VR ALT Rennen in Imola hab ich mit Mühe und Not grad mal so 45fps halten können. Niedrige/mittlere Grafikdetails, Effekte runtergeschraubt, Shaderpatch-Optimierungen aktiv und Supersampling gerademal auf 110%.

Ich hab auch mal andere Shader-Patch-Versionen getestet und auch mal sämtliche Apps deaktiviert. Das brachte nur ein minimales Performance-Plus.

Was mich stutzig macht ist, dass ich im fpsVR-Tool sehe, dass die Auslastung der Grafikkarte, als auch der CPU nur jeweils auf ca. 50% ist. Wenn hier eine Komponente der Flaschenhals wäre, dann sollte doch diese annähernd 100% Auslastung haben, oder sehe ich das falsch?

Ich bin irgendwie ratlos, denn z.B. rFactor2 läuft mit hohen Details und höherem Supersampling butterweich mit konstanten 90fps.
 
U

User 9942

Es zeigt nach meiner Meinung die gesamte Auslastung der CPUs. Ich hab in der VRLN ähnliche Erfahrungen gemacht. CPU und GPU wird laut fpsVR zu 50% ausgelastet FPS bleiben aber bei 45 hängen. Zeitgleich aber immer mal 99% CPU Auslastungswarnungen von AC.

Liegt glaub ich daran, dass AC große Grids nicht gut skalieren kann und damit die benötigte CPU Power ernorm ansteigt. Das ist bei anderen Sims anders hab ich das gefühlt.
 
U

User 14075

Das liegt daran, dass AC nur einen Core auslastet. 50% CPU über fpsVR verrät, dass fpsVR die komplette CPU (also alle Kerne zusammen) anzeigt, aber nicht darstellt, ob ein Kern komplett ausgelastet ist. Für AC ist also der Singlecore Takt extrem wichtig. 4,8GHz oder gar 5GHz helfen hier wunder.
 
Zuletzt bearbeitet:
U

User 12216

Wie viele Fahrzeuge waren denn auf dem ALT-Server?
Für mich sieht das ganz klar nach einem CPU-Bottleneck aus.
Der 6700K auf 4,6 Ghz leistet weniger als mein alter 4790K auf 4,9 Ghz, mit dem ich genau die gleichen Probleme hatte.
Selbst mit meinem 9900K, der jetzt auf 5,1 Ghz läuft, hatte ich beim letzten FAC-Rennen mit 30 Startern immer wieder leichte Framedrops auf 85 FPS, die CPU-bedingt waren.
Du könntest mal das Programm Process Lasso ausprobieren. Damit kannst du Prozesse dauerhaft bestimmten Kernen zuweisen.
Ich habe AC damals auf meinem alten Prozessor den Kernen 0-6 zugewiesen und die ganze Zusatzprogramme auf den virtuellen Kern 7 festgenagelt.
Das hat einiges an FPS gebracht. Natürlich nicht bis 90 FPS, aber zumindest so viel, dass ich immer deutlich über 45 war und ASW problemlos lief.
Ich nutze das Programm auch mit meinem 9900k weiter, da ich die Erfahrung gemacht habe, dass die feste Kernzuteilung gerade bei großen Fahrerfeldern deutlich besser funktioniert als die automatische Threadzuordnung von Windows. Mit der habe ich auch mit dem 9900k bei einem vollen Fahrerfeld massive FPS-Probleme.
 
U

User

Selbst mit meinem 9900K, der jetzt auf 5,1 Ghz läuft, hatte ich beim letzten FAC-Rennen mit 30 Startern immer wieder leichte Framedrops auf 85 FPS, die CPU-bedingt waren.

Poste mal alle deine Einstellungen, AC + CSP falls installiert. Da ist irgendwas konfiguriert, was bullshit ist.
Und schaue mal, wenn du so eine Situation hast, auf die Temperatur von der CPU (wobei die bei einer Belastung von 2-3 Kernen ohne Probleme zu halten sein sollte)
 
U

User 4396

Danke schonmal für die Tipps. Ich hab ja auch die Vermutung, dass meine CPU der Flaschenhals ist, denn mein 6700K ist ja nicht mehr ganz taufrisch. Aber ich war eben in fpsVR verwundert, dass die CPU-Auslastung nicht wirklich hoch war. Kann natürlich mit den Kernen/Threads zusammenhängen. Ich muss das mal checken.

Wie viele Fahrzeuge waren denn auf dem ALT-Server?
Ich glaub, es waren 32 am Start.
Multiplayer muss einen größeren Einfluß haben, denn im Singleplayer hab ich höhere FPS, selbst wenn ich die gleiche Anzahl an KI hinzufüge.
 
U

User 12216

Die temps sind kein Problem, das hatte ich schon gecheckt. (Es ist zwar nur eine AiO-Wakü, aber ne 360er die immer auf voller Lüsterdrehzahl läuft, da mir die Geräuschentwicklung egal ist)
Und meine Einstellungen in CSP sind nach deiner Anleitung vorgenommen, sollte also auch passen.
Meine Vermutung ist die halbgare Implemetierung von OpenVR in Assetto. SteamVR und noch Windows Mixed Reality for SteamVr ist grundsätzlich deutlich CPU-lntensiver als die reine Oculus-Schnittstelle. Ein Indikator dafür ist auch die Main-Thread-Anzeige der FPS-App in Assetto.
Mit Oculus hat man alleine auf der Strecke ca. 20 Prozent Auslastung, mit OpenVR hängt man alleine bei 97 % Auslastung, die dann auf dem Server mit steigender Last sogar leicht sinkt. Da fehlt es mMn einfach massiv an Optimierung. Das hat Stefano damals kurz implementiert so dass es lief, aber optimiert wurde es nie (Ich meine er hatte nach der Veröffentlichung des damaligen Patches auch gesagt, dass da noch was kommt, weshalb es im Menü als "Open-VR (Beta)" tituliert ist, aber diese Optimierung fiel dann leider hinten runter.

Ich glaub, es waren 32 am Start.
Multiplayer muss einen größeren Einfluß haben, denn im Singleplayer hab ich höhere FPS, selbst wenn ich die gleiche Anzahl an KI hinzufüge.

Wenn das so ist, ist da aber wirklich was nicht ganz normal...ich habe bei gleicher KI-Anzahl definitiv immer weniger FPS als online. Hmmm...?(
 
Zuletzt bearbeitet:
Oben